Fix for "Cannot complete the install because of a conflicting dependency."

When plug-in installation fails in newer versions of Eclipse (such as "e4"), you may have to deal with cryptic error messages such as this one:

Cannot complete the install because of a conflicting dependency.
 Software being installed: EPIC 0.6.39 (org.epic.feature.main.feature.group 0.6.39)
 Software currently installed: Eclipse SDK 4.1.0.I20110312-1300 (org.eclipse.sdk.ide 4.1.0.I20110312-1300)
 Only one of the following can be installed at once:
   Core Runtime 3.6.100.v20101122 (org.eclipse.core.runtime 3.6.100.v20101122)
   Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
 Only one of the following can be installed at once:
   Equinox Launcher Linux X86 Fragment 1.1.100.v20110321 (org.eclipse.equinox.launcher.gtk.linux.x86 1.1.100.v20110321)
   Equinox Launcher Linux X86 Fragment 1.1.100.v20101018 (org.eclipse.equinox.launcher.gtk.linux.x86 1.1.100.v20101018)
 Only one of the following can be installed at once:
   Equinox Java Authentication and Authorization Service (JAAS) 1.1.0.v20110411 (org.eclipse.equinox.security 1.1.0.v20110411)
   Equinox Java Authentication and Authorization Service (JAAS) 1.1.0.v20101004 (org.eclipse.equinox.security 1.1.0.v20101004)
   Equinox Java Authentication and Authorization Service (JAAS) 1.1.0.v20110124-0830 (org.eclipse.equinox.security 1.1.0.v20110124-0830)
 Only one of the following can be installed at once:
   Refactoring UI 3.5.100.v20101012-0800 (org.eclipse.ltk.ui.refactoring 3.5.100.v20101012-0800)
   Refactoring UI 3.6.0.v20110307-2000a (org.eclipse.ltk.ui.refactoring 3.6.0.v20110307-2000a)
   Refactoring UI 3.5.100.v20110111-0800 (org.eclipse.ltk.ui.refactoring 3.5.100.v20110111-0800)
 Only one of the following can be installed at once:
   Eclipse Platform 4.1.0.v20110420-1420 (org.eclipse.platform 4.1.0.v20110420-1420)
   Eclipse Platform 4.1.0.v20110415-1401 (org.eclipse.platform 4.1.0.v20110415-1401)
   Eclipse Platform 3.7.0.v201104210100 (org.eclipse.platform 3.7.0.v201104210100)
   Eclipse Platform 3.7.0.v201103101119 (org.eclipse.platform 3.7.0.v201103101119)
   Eclipse Platform 4.1.0.v20110407-2200 (org.eclipse.platform 4.1.0.v20110407-2200)
   Eclipse Platform 4.1.0.v20110415-1030 (org.eclipse.platform 4.1.0.v20110415-1030)
   Eclipse Platform 3.7.0.v201103220800 (org.eclipse.platform 3.7.0.v201103220800)
   Eclipse Platform 3.7.0.v201104061223 (org.eclipse.platform 3.7.0.v201104061223)
   Eclipse Platform 4.1.0.v20110412-2200 (org.eclipse.platform 4.1.0.v20110412-2200)
   Eclipse Platform 3.7.0.v201104121532 (org.eclipse.platform 3.7.0.v201104121532)
   Eclipse Platform 3.7.0.v201104211800 (org.eclipse.platform 3.7.0.v201104211800)
   Eclipse Platform 4.1.0.v20110127-2200 (org.eclipse.platform 4.1.0.v20110127-2200)
   Eclipse Platform 3.7.0.v201102150800 (org.eclipse.platform 3.7.0.v201102150800)
   Eclipse Platform 4.1.0.v20101202-1530 (org.eclipse.platform 4.1.0.v20101202-1530)
   Eclipse Platform 4.1.0.v20110312-1300 (org.eclipse.platform 4.1.0.v20110312-1300)
   Eclipse Platform 4.1.0.v20110325-1411 (org.eclipse.platform 4.1.0.v20110325-1411)
   Eclipse Platform 4.1.0.v20110419-2200 (org.eclipse.platform 4.1.0.v20110419-2200)
   Eclipse Platform 3.7.0.v201012081300 (org.eclipse.platform 3.7.0.v201012081300)
   Eclipse Platform 4.1.0.v20110422-0200 (org.eclipse.platform 4.1.0.v20110422-0200)
   Eclipse Platform 4.1.0.v20110421-0500 (org.eclipse.platform 4.1.0.v20110421-0500)
   Eclipse Platform 4.1.0.v20110414-2200 (org.eclipse.platform 4.1.0.v20110414-2200)
   Eclipse Platform 3.7.0.v201104191004 (org.eclipse.platform 3.7.0.v201104191004)
 Cannot satisfy dependency:
   From: Equinox p2 Provisioning for IDEs 2.1.0.v20110228-897TFncFdHjO2qRuCh_UvYT (org.eclipse.equinox.p2.user.ui.feature.group 2.1.0.v20110228-897TFncFdHjO2qRuCh_UvYT)
   To: org.eclipse.equinox.security [1.1.0.v20110124-0830]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.r20110302-9gF7SHCIFt6ms-lIjrC6vK_XO-IabJMKu (org.eclipse.platform.feature.group 3.7.0.r20110302-9gF7SHCIFt6ms-lIjrC6vK_XO-IabJMKu)
   To: org.eclipse.platform [3.7.0.v201103101119]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20100923-9fF7MHDqFsAkplGz0n61z-yU57WHoz0JdMfaI (org.eclipse.platform.feature.group 3.7.0.v20100923-9fF7MHDqFsAkplGz0n61z-yU57WHoz0JdMfaI)
   To: org.eclipse.rcp.feature.group [3.7.0.v20101115-9FB-FqhFr3P05j0S-HRVgSR]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110209-9fF7QHFQFsAlpyfO4rKw4lNW200gZcvGr (org.eclipse.platform.feature.group 3.7.0.v20110209-9fF7QHFQFsAlpyfO4rKw4lNW200gZcvGr)
   To: org.eclipse.ltk.ui.refactoring [3.5.100.v20110111-0800]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHCJFt3cwDesZ5LrhrcdfooveV1uWqcqPF (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHCJFt3cwDesZ5LrhrcdfooveV1uWqcqPF)
   To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5FiuFpBGyIDVb_FRbwWP]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHIZFt3cwDktE9WrW9XEj1iOiW9fgbhxME (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHIZFt3cwDktE9WrW9XEj1iOiW9fgbhxME)
   To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5FiuFpBGyImVoOcTaz-ZS]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHLgFt4cwDmoWF-DvhVMEUrQfXBVSritR5 (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHLgFt4cwDmoWF-DvhVMEUrQfXBVSritR5)
   To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5FiuFpBGyIxIrTOSarWQ]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHNFFt4cwDooaDrDsaVdEWi0oMLWlh6mbT (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHNFFt4cwDooaDrDsaVdEWi0oMLWlh6mbT)
   To: org.eclipse.equinox.security [1.1.0.v20110411]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHNFFt4cwDqmhLPCtURdWWmWmO0Plh6mbT (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHNFFt4cwDqmhLPCtURdWWmWmO0Plh6mbT)
   To: org.eclipse.equinox.security [1.1.0.v20110411]
 Cannot satisfy dependency:
   From: Eclipse Platform 3.7.0.v20110315-9gF7SHNFFt4cwDrmlStE-Ufz0RVqQoc8RS8f2gQ (org.eclipse.platform.feature.group 3.7.0.v20110315-9gF7SHNFFt4cwDrmlStE-Ufz0RVqQoc8RS8f2gQ)
   To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5FiuFpBGyY_VrXOSeaUQ]
 Cannot satisfy dependency:
   From: Eclipse Platform 4.1.0.v20110303-9IF70GdMFnUTMd104-mz-W9mNz0ESwPlAOa-_otA7mYeU (org.eclipse.platform.feature.group 4.1.0.v20110303-9IF70GdMFnUTMd104-mz-W9mNz0ESwPlAOa-_otA7mYeU)
   To: org.eclipse.ltk.ui.refactoring [3.6.0.v20110307-2000a]
 Cannot satisfy dependency:
   From: Eclipse Platform 4.1.0.v20110303-9IF70GdMFnUTMd104-mz-W9mNz0ESwPlAOa-_otA7mYeU (org.eclipse.platform.feature.group 4.1.0.v20110303-9IF70GdMFnUTMd104-mz-W9mNz0ESwPlAOa-_otA7mYeU)
   To: org.eclipse.platform [4.1.0.v20110312-1300]
 Cannot satisfy dependency:
   From: Eclipse Product Configuration 1.0.0.I20110310-1119 (org.eclipse.rcp.configuration.feature.group 1.0.0.I20110310-1119)
   To: org.eclipse.equinox.launcher.gtk.linux.x86 [1.1.100.v20101018]
 Cannot satisfy dependency:
   From: Eclipse RCP 3.7.0.v20101115-9FB-FqhFr3P05j0S-HRVgSR (org.eclipse.rcp.feature.group 3.7.0.v20101115-9FB-FqhFr3P05j0S-HRVgSR)
   To: org.eclipse.core.runtime [3.6.100.v20101122]
 Cannot satisfy dependency:
   From: Eclipse RCP 3.7.0.v20110216-9DB5FiuFpBGyIDVb_FRbwWP (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5FiuFpBGyIDVb_FRbwWP)
   To: org.eclipse.equinox.launcher.gtk.linux.x86 [1.1.100.v20110321]
 Cannot satisfy dependency:
   From: Eclipse RCP 3.7.0.v20110216-9DB5FiuFpBGyImVoOcTaz-ZS (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5FiuFpBGyImVoOcTaz-ZS)
   To: org.eclipse.equinox.launcher.gtk.linux.x86 [1.1.100.v20110321]
 Cannot satisfy dependency:
   From: Eclipse RCP 3.7.0.v20110216-9DB5FiuFpBGyIxIrTOSarWQ (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5FiuFpBGyIxIrTOSarWQ)
   To: org.eclipse.equinox.launcher.gtk.linux.x86 [1.1.100.v20110321]
 Cannot satisfy dependency:
   From: Eclipse RCP 3.7.0.v20110216-9DB5FiuFpBGyY_VrXOSeaUQ (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5FiuFpBGyY_VrXOSeaUQ)
   To: org.eclipse.equinox.launcher.gtk.linux.x86 [1.1.100.v20110321]
 Cannot satisfy dependency:
   From: Eclipse Project SDK 4.1.0.v20110303-7T7fA7F8Yw_bVbCrFz-gFceimF7IZRyogX1MAdUyRWqYu (org.eclipse.sdk.feature.group 4.1.0.v20110303-7T7fA7F8Yw_bVbCrFz-gFceimF7IZRyogX1MAdUyRWqYu)
   To: org.eclipse.platform.feature.group [4.1.0.v20110303-9IF70GdMFnUTMd104-mz-W9mNz0ESwPlAOa-_otA7mYeU]
 Cannot satisfy dependency:
   From: Eclipse SDK 4.1.0.I20110312-1300 (org.eclipse.sdk.ide 4.1.0.I20110312-1300)
   To: org.eclipse.equinox.p2.user.ui.feature.group [2.1.0.v20110228-897TFncFdHjO2qRuCh_UvYT]
 Cannot satisfy dependency:
   From: Eclipse SDK 4.1.0.I20110312-1300 (org.eclipse.sdk.ide 4.1.0.I20110312-1300)
   To: org.eclipse.rcp.configuration.feature.group [1.0.0.I20110310-1119]
 Cannot satisfy dependency:
   From: Eclipse SDK 4.1.0.I20110312-1300 (org.eclipse.sdk.ide 4.1.0.I20110312-1300)
   To: org.eclipse.sdk.feature.group [4.1.0.v20110303-7T7fA7F8Yw_bVbCrFz-gFceimF7IZRyogX1MAdUyRWqYu]
 Cannot satisfy dependency:
   From: Eclipse SDK 4.1.0.I20110312-1300 (org.eclipse.sdk.ide 4.1.0.I20110312-1300)
   To: toolingorg.eclipse.sdk.ide.configuration [4.1.0.I20110312-1300]
 Cannot satisfy dependency:
   From: EPIC 0.6.39 (org.epic.feature.main.feature.group 0.6.39)
   To: org.eclipse.platform.feature.group [3.2.0,4.0.0)
 Cannot satisfy dependency:
   From: toolinggtk.linux.x86org.eclipse.core.runtime 4.1.0.I20110312-1300
   To: bundle org.eclipse.core.runtime 3.7.0.v20110110
 Cannot satisfy dependency:
   From: toolingorg.eclipse.sdk.ide.configuration 4.1.0.I20110312-1300
   To: toolinggtk.linux.x86org.eclipse.core.runtime [4.1.0.I20110312-1300]

The usability problems with this error message are evident: excessive length, lack of focus, little clue for the developer about possible solutions (and even less for a mere user who is just trying to install a plug-in). Paradoxically, the best way to even know which parts of the error message are relevant at all is to have already solved the problem at hand. Having done just this, here are some possibly helpful inferences:

  • Chances that you are going to solve a problem of this sort as a normal user are slight. The error likely lies in dependency declarations contained in feature.xml descriptors that are being processed by the installer and you cannot/are not supposed to manually edit those. It's safe to assume that it's the developers' job to sort out this mess. The remaining bullet points address how.
  • The "Only one of the following can be installed at once" parts of the message are misleading and should be ignored as noise.
  • The "Cannot satisfy dependency" parts might be relevant, however most of them are bogus, resulting from error propagation, and should be ignored as noise as well.
  • The root cause is likely contained in the feature.xml descriptor of whatever it is that you are trying to install. In the above example my installation attempt concerns the EPIC IDE, and only the following short snippet from the bottom of the error message actually matters:
     Cannot satisfy dependency:
       From: EPIC 0.6.39 (org.epic.feature.main.feature.group 0.6.39)
       To: org.eclipse.platform.feature.group [3.2.0,4.0.0)
    
  • The above dependency comes from a line in content.xml, a file which is found within content.jar downloaded by the installer from the update site. In my case the relevant line of content.xml looked like so:
    <required namespace='org.eclipse.equinox.p2.iu'
             name='org.eclipse.platform.feature.group'
             range='[3.2.0,4.0.0)'/>
    
  • The file content.xml is a generated one, so to fix the problem (by removing the line) the developer must track back to the input files that are under his control. In my case it was feature.xml, which contained the following "offending" snippet:
      <requires>
         <import feature="org.eclipse.platform"
                    version="3.2.0"
                    match="compatible"/>
      </requires>
    

Eventually, changing match="compatible" to match="greaterOrEqual" in feature.xml and rebuilding content.jar fixed the cause of the original messy error message, as was to be expected ("compatible" means only compatible within the major version, i.e. "3.x.x"). After the fix content.xml contains range="3.2.0", which is fine for installation in 4.1.0.

11 comments:

Mohamed Tair said...

i have this problem:
Cannot complete the install because of a conflicting dependency.
Software being installed: Android Traceview 16.0.1.v201112150204-238534 (com.android.ide.eclipse.traceview.feature.group 16.0.1.v201112150204-238534)
Software currently installed: Eclipse IDE for PHP Developers 1.3.0.20100617-0520 (epp.package.php 1.3.0.20100617-0520)
Only one of the following can be installed at once:
Eclipse UI 3.6.1.M20100826-1330 (org.eclipse.ui 3.6.1.M20100826-1330)
Eclipse UI 3.6.2.M20110203-1100 (org.eclipse.ui 3.6.2.M20110203-1100)
Eclipse UI 3.6.0.I20100603-1100 (org.eclipse.ui 3.6.0.I20100603-1100)
Cannot satisfy dependency:
From: Android Traceview 16.0.1.v201112150204-238534 (com.android.ide.eclipse.traceview.feature.group 16.0.1.v201112150204-238534)
To: org.eclipse.ui 3.6.2
Cannot satisfy dependency:
From: Eclipse IDE for PHP Developers 1.3.0.20100617-0520 (epp.package.php 1.3.0.20100617-0520)
To: org.eclipse.epp.package.php.feature.feature.group [1.3.0.20100617-0520]
Cannot satisfy dependency:
From: EPP PHP Feature 1.3.0.20100617-0520 (org.eclipse.epp.package.php.feature.feature.group 1.3.0.20100617-0520)
To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
To: org.eclipse.rcp.feature.group [3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS]
Cannot satisfy dependency:
From: Eclipse RCP 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS (org.eclipse.rcp.feature.group 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS)
To: org.eclipse.ui [3.6.0.I20100603-1100]

Anonymous said...

@Mohamed Tair
I have been having the same problem working on it all day and finally figured out a solution. Go to Help>Check for Updates. If there is an update there, install it and your issue should be fixed. I installed Eclipse for the first time 2 hours ago and was surprised to see an update needed, but it worked. Good luck!

straight_from_audience said...

i am facing this problem while linking android sdk to eclipse helios
Cannot complete the install because of a conflicting dependency.
Software being installed: Android DDMS 16.0.1.v201112150204-238534 (com.android.ide.eclipse.ddms.feature.group 16.0.1.v201112150204-238534)
Software currently installed: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
Only one of the following can be installed at once:
Eclipse UI 3.6.1.M20100826-1330 (org.eclipse.ui 3.6.1.M20100826-1330)
Eclipse UI 3.6.2.M20110203-1100 (org.eclipse.ui 3.6.2.M20110203-1100)
Eclipse UI 3.6.0.I20100603-1100 (org.eclipse.ui 3.6.0.I20100603-1100)
Cannot satisfy dependency:
From: Android DDMS 16.0.1.v201112150204-238534 (com.android.ide.eclipse.ddms.feature.group 16.0.1.v201112150204-238534)
To: org.eclipse.ui 3.6.2
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
To: org.eclipse.epp.package.jee.feature.feature.group [1.3.1.20100916-1202]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.3.1.20100916-1202 (org.eclipse.epp.package.jee.feature.feature.group 1.3.1.20100916-1202)
To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.rcp.feature.group [3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T]
Cannot satisfy dependency:
From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
To: org.eclipse.ui [3.6.1.M20100826-1330]

Anonymous said...

Cannot complete the install because of a conflicting dependency.
Software being installed: Android DDMS 16.0.1.v201112150204-238534 (com.android.ide.eclipse.ddms.feature.group 16.0.1.v201112150204-238534)
Software currently installed: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
Only one of the following can be installed at once:
Eclipse UI 3.6.1.M20100826-1330 (org.eclipse.ui 3.6.1.M20100826-1330)
Eclipse UI 3.6.2.M20110203-1100 (org.eclipse.ui 3.6.2.M20110203-1100)
Eclipse UI 3.6.0.I20100603-1100 (org.eclipse.ui 3.6.0.I20100603-1100)
Cannot satisfy dependency:
From: Android DDMS 16.0.1.v201112150204-238534 (com.android.ide.eclipse.ddms.feature.group 16.0.1.v201112150204-238534)
To: org.eclipse.ui 3.6.2
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.3.1.20100916-1202 (epp.package.jee 1.3.1.20100916-1202)
To: org.eclipse.epp.package.jee.feature.feature.group [1.3.1.20100916-1202]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.3.1.20100916-1202 (org.eclipse.epp.package.jee.feature.feature.group 1.3.1.20100916-1202)
To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L]
Cannot satisfy dependency:
From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)
To: org.eclipse.rcp.feature.group [3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T]
Cannot satisfy dependency:
From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
To: org.eclipse.ui [3.6.1.M20100826-1330]
plz help for this error , i'm not even able to make an update, same error pops

Anonymous said...

"Go to Help>Check for Updates. If there is an update there, install it and your issue should be fixed. I installed Eclipse for the first time 2 hours ago and was surprised to see an update needed, but it worked. Good luck! "

This worked perfectly for me.

Robin Carnow said...

I can't believe that this inadequate system for plugin management was allowed into eclipse. It is just sad especially when you know that there a package management systems (e.g. deb) that work flawlessly.

Anonymous said...

Yes, I agree. The check for update option solved my same problem when trying to add Android Dev plugins.

Henry Krause said...

I have this mess almost every time I try to install something from the marketplace.
Check for updates doesn't help, because it raises the same error messages.
The only thing that was working for me was to manually deinstall all plugins holding the mentioned conflicting dependencies an then reinstalling everything again with the newest version.

This is very time consuming and frustrating!

Anonymous said...

It's a phuck*ing nightmare !

Ali Android said...

One simple slution is uninstall adt
then reinstall it
http://stackoverflow.com/questions/9097163/uninstalling-android-adt

Isra said...

I write this message in August 2015, I see comments posted here for a long time ago ... is this the longest unresolved bug ever?

Post a Comment